Проблема с установкой Java старой JRE

В моей компании у нас есть внутреннее приложение, которое использует Java. Очевидно, что он должен использовать 7.0.5, так как приложение перестает работать на машинах, которые были обновлены до 7.0.7. У нас есть установщик, хранящийся в сети здесь, о котором я изначально не был уведомлен. Вот ситуация.

  • Две идентичные машины: «Ноутбук А» и «Ноутбук Б»
  • Я загрузил копию jre-7u5 с oldversion.com и установил ее на Laptop A.
  • Java не работает в firefox на ноутбуке A (согласно javatester.org, а также java-сайте oracle). Я установил extensions.blocklist.enabled на "false", а plugins.hide_infobar_for_outdated_plugin – на "true"
  • Я узнал об установщике, который у нас уже был, прежде чем попасть в ноутбук. Видя, как это было на NAS, я использовал его для установки на ноутбуке B, и он отлично работает. Я удалил java на ноутбуке A и переустановил его с помощью нашего «известного хорошего» установщика, но безрезультатно.

Есть ли способ разрешить это? Если нет, ноутбук может быть реквизирован для другого отдела, который не использует наше настраиваемое приложение, но было бы лучше, если бы я мог это сделать.

One Solution collect form web for “Проблема с установкой Java старой JRE”

Попробуйте JavaRa полностью удалить все следы старых установок Java:

Введите описание изображения здесь

Давайте будем гением компьютера.